Projekt ESP32 Arduino RC Sound und Licht Controller

Onkel_Tom

Mitglied
Super übrigens, du scheinst Fortschritte zu machen. Bilder
Noch nicht wirklich. Gelötet ist alles davon gibts ja auch Bilder, aber sonst ist noch nicht viel bis nix passiert.
Hab zumindest jetzt meine Kabel um den Empfänger mit dem Board zu verbinden.
Bei den ersten zwei versuchen zu Programmieren bin ich kläglich gescheitert.
Starte jetzt am WE den nächsten Versuch ;)
 

BAXL

Admin
Mitarbeiter
Wären Probleme bei der reinen Inbetriebnahme, also eben Probleme beim Programmieren, nicht ein eigenes Thema wert, weil das idR. etwas mit den Einstellungen und Einbinden von erforderlichen Libraries zu tun hat, sowie der Auswahl des richtigen Moduls in der IDE.
 
Ich denke das Beste wäre nicht ein separates Thema, sondern ein aktuell gehaltener Post mit aufgetretenen Problemen und Lösungen bei der Inbetriebnahme, auf den dann aus dem ersten Post heraus verlinkt wird.
 
dieser Thread ist ab sofort reserviert für aufgetretene Probleme und Lösungen
Er wird Im Post #1 verlinkt und dient als zentrale Referenz

1. Nicht oder falsch installierte Library
Problem:

Fehlende Libraries produzieren beim Kompilieren Meldungen wie diese:
Bildschirmfoto 2021-02-24 um 06.39.11.png

Lösung:
Die folgenden Libraries installieren:
Bildschirmfoto 2021-02-23 um 06.11.13.png
Libraries gehören NICHT in den Sketch-Ordner. Wie das gemacht wird, ist z.B. hier zu finden:
 
Zuletzt bearbeitet:

Onkel_Tom

Mitglied
:confused: meine Fortschritte werden immer hier
20210222_233136.jpg
gebremst. Da komm ich nicht weiter. Ob später meine einfache Funke unter PWM Einstellung funktioniert weiß ich auch noch nicht.
Zumindest scheint da die Einstellung ok zu sein...

Vielleicht bin ich doch nicht fürs Programmieren gemacht
 

Onkel_Tom

Mitglied
ZIP Datei runtergeladen, entpackt und dann in den Sketch Ordner kopiert.
Liegt tendenziell am Einstellen der Konfiguration, an der ich momentan noch scheitere. Alle anderen Datein hab ich auf die gleiche Weise erstellt.
Elektronik ist halt nicht so ganz mein Ding.
 

kiteklaus

Mitglied
ZIP Datei runtergeladen, entpackt und dann in den Sketch Ordner kopiert.
Liegt tendenziell am Einstellen der Konfiguration, an der ich momentan noch scheitere. Alle anderen Datein hab ich auf die gleiche Weise erstellt.
Elektronik ist halt nicht so ganz mein Ding.
Moin Onkel Tom,
für mich sie sieht das so aus als wenn die Libarys nicht richtig installiert sind.
Librarys herunter laden, entzippen und die entpackten Ordner dann in den Ordner Arduino/librarys kopieren.
Dann sollte das funktionieren.

VG Klaus
 
Hier kommt eine neue Version mit:
Bildschirmfoto 2021-02-24 um 07.35.38.png
ACHTUNG:
  • Im PWM Kommunikationsmodus dürfen KEINE Servos an die CHx Pins angeschlossen werden! Funktioniert also nur mit SBUS, PPM & IBUS
  • Der TAMIYA Schalter in der Sattelplatte muss an GND und pin 32 angeschlossen werden. Die Funktion muss gemäss oben aktiviert werden. In diesem Modus darf KEINE LED an pin 32 angeschlossen werden!
  • Funktioniert nur mit dem #define FLYSKY_FS_I6X Profil in "2_adjustmentsRemote.h"
  • Kanalbelegung siehe "adjustmentsRemote.xlsx"
 

kiteklaus

Mitglied
Cool, leider hängen die Platinen immer noch im Zoll in Leipzig fest, ich hoffe die schaffen es noch bis um Wochenende, vielen Dank schon mal für das schnelle einbauen der Trailer Sounds.

VG Klaus
 

kiteklaus

Mitglied
Moin Martin, meine Platinen hängen immer noch im Zoll in Leipzig fest, keine Ahnung was das soll :mad:...
Ich hab mir deshalb mal die neue Software angesehen ohne etwas probieren zu können. Aufgefallen ist mir dabei folgendes: Du benutzt den Kanal 4 für den Servo der die Sattelplatte steuert, aber da scheint ja noch etwas anderes auf dem Kanal zu liegen? Vom Prinzip her baucht man natürlich erst mal nur ein auf und zu der Sattelplatte, aber wenn man auch noch die elektrischen Stützen am Trailer hat, sieht das etwas anders aus. Ich versuche mal dir zu beschreiben wie sich die Funktion dann darstellt:
wenn der Servo auf "neutral" steht ist die Sattelplatte geschlossen, fährt er auf +100% ist sie offen, soweit ist das ja auch in deiner Software umgesetzt wenn ich das richtig verstehe. Es gibt aber noch zwei weitere Stellungen die wichtig wären.
Wenn man das Servo auf -75% fährt werden die Stützen am Trailer ausgefahren und wenn man das Servo auf -100% fährt, werden die Stützen eingefahren. Um dieses tun zu können wird also Dual Rate oder ein Mischer auf dem Kanal 4 benötigt und es dürfen keine weiteren Funktionen auf dem Kanal liegen. Am besten wäre es meiner Ansicht nach den Kanal einfach durchzureichen ohne ihn zu verändern. Ich hänge dir noch Fotos der Sattelplatte an, wo man erkennen kann, wie die Stützen am Trailer bedient werden, der Hebel an der Sattelplatte links oben im Bild betätigt den Schalter unter dem Trailer für die Funktion.
IMG_20210226_123224[1].jpgIMG_20210226_123237[1].jpg
VG Klaus
 
Zuletzt bearbeitet:
Du benutzt den Kanal 4 für den Servo der die Sattelplatte steuert, aber da scheint ja noch etwas anderes auf dem Kanal zu liegen?
Hallo Klaus. Ja, gemäss dem Excel die Blinker bei 100% Dual Rate und bei 75% links Warnblinker und rechts Sattelplatte abwechselnd öffnen / schliessen:
Bildschirmfoto 2021-02-27 um 08.36.45.png
Der Kanal wird also nicht proportional an das Servo durchgereicht, sondern es werden die programmieren Endpunkte abwechselnd angefahren:
Bildschirmfoto 2021-02-27 um 08.40.03.png

Am besten wäre es meiner Ansicht nach den Kanal einfach durchzureichen ohne ihn zu verändern.
Das sehe ich anders. ich würde 3 Punkte im Soundcontroller programmieren, die dann mit der entsprechenden Sequenz angefahren werden. Dazu müsstest du diese mittels Ablaufdiagramm definieren, da ich keine automatischen Stützen habe.
 

kiteklaus

Mitglied
Über eine Sequenz wird das sehr schwierig, da der Trailer keine Endschalter in den Stützen verbaut hat. Man muss die Punkte als per Hand über den Sender zum richtigen Zeitpunkt steuern können.
 
OK, hat der Stützenmotor wenigstens eine Ruschkupplung, oder was passiert, wenn du zu lange das Signal gibst? Dann muss ich mir das noch überlegen. Ich denke, du solltest mal alles aufbauen und mit manuellen Stützen starten. Das Ent- und Verriegeln der Sattelplatte kannst du ja wie oben beschrieben programmieren. Wenn alles andere funktioniert, reden wir nochmal drüber.
 
Top Bottom